1 (edited by chadm 2011-07-30 13:56:47)

Topic: Recipient address rejected: Policy Rejection- Please try later.

I just installed iRedMail and I am trying to figure out where the greylisting is configured. When sending from my gmail account to the new iRedMail install I see the following message in the logs. (Email addresses edited)

Jul 30 05:45:14 mail policyd: rcpt=5, greylist=new, host=209.85.213.179 (unknown), from=me@gmail.com, to=me@iredmailserver.com, size=0 
Jul 30 01:45:14 mail postfix/smtpd[3358]: NOQUEUE: reject: RCPT from unknown[209.85.213.179]: 450 4.7.1 <me@iredmailserver.com>: Recipient address rejected: Policy Rejection- Please try later.; from=<me@gmail.com> to=<me@iredmailserver.com> proto=ESMTP helo=<mail-yx0-f179.google.com>
Jul 30 01:45:14 mail postfix/smtpd[3358]: disconnect from unknown[209.85.213.179]

It seems messages are eventually delivered after some delay (15 - 30 mins)

Is it possible to disable greylisting completely in iRedMail?

Also, why is the policyd time stamp not correct? The date on my server is correct.

[root@mail www]# date
Sat Jul 30 01:52:55 EDT 2011

Thanks in advance.

==== Provide basic information to help troubleshoot ====
- iRedMail version: iRedMail-0.7.2  w/ iRedAdmin-Pro-MySQL-1.2.1
- Linux/BSD distribution name and version: CentOS 5.6
- Any related log? Log is helpful for troubleshooting.
====

2

Re: Recipient address rejected: Policy Rejection- Please try later.

chadm wrote:

Is it possible to disable greylisting completely in iRedMail?

Disable greylisting in /etc/policyd.conf, then restart policyd service.

chadm wrote:

Also, why is the policyd time stamp not correct? The date on my server is correct.

Known issue on RHEL/CentOS 5.x, bug in syslog.