1

Topic: Trying a re-install, skips all however!

Hey,

I recently stumbled upon iRedMail. The implementation certainly suits my needs, however, I had a server running with Postfix and the whole anti-spam/virus circus already.

Basicly I tried the installer and it worked, it downloaded all packages and installed them. It was working untill some extent. Not completely however, because when I tried sending e-mails it would always generate some vague error about a "451 4.3.5 server configuration problem". I didn't manage to solve this, so I decided to remove it all and start over with a more clean situation.

So I removed all the software, and also ran the uninstall script from iRedMail.

Now i'm trying to re-install iRedMail. It starts the bash iRedMail, and it asks me for all the configuration details, however, once it asks me if I want to continue this is the result:

<<< SKIP >>> Skip function: install_all_pkgs.
<<< SKIP >>> Skip function: enable_all_services.
<<< SKIP >>> Skip function: adduser_vmail.
<<< SKIP >>> Skip function: apache_php_config.
<<< SKIP >>> Skip function: mysql_initialize.
<<< SKIP >>> Skip function: mysql_import_vmail_users.
<<< SKIP >>> Skip function: postfix_config_basic.
<<< SKIP >>> Skip function: postfix_config_virtual_host.
<<< SKIP >>> Skip function: postfix_config_sasl.
<<< SKIP >>> Skip function: postfix_config_tls.
<<< SKIP >>> Skip function: policy_service_config.
<<< SKIP >>> Skip function: enable_dovecot.
<<< SKIP >>> Skip function: procmail_config.
<<< SKIP >>> Skip function: clamav_config.
<<< SKIP >>> Skip function: amavisd_config_rhel.
<<< SKIP >>> Skip function: amavisd_config_general.
<<< SKIP >>> Skip function: amavisd_import_sql.
<<< SKIP >>> Skip function: sa_config.
<<< SKIP >>> Skip function: rcm_install.
<<< SKIP >>> Skip function: rcm_config_httpd.
<<< SKIP >>> Skip function: rcm_import_sql.
<<< SKIP >>> Skip function: rcm_config.
/tmp/iRedMail-0.7.2/functions/roundcubemail.sh: line 348: cd: /var/www/roundcubemail-0.5.3/config/: No such file or directory
/tmp/iRedMail-0.7.2/functions/roundcubemail.sh: line 352: cd: /var/www/roundcubemail-0.5.3/plugins/managesieve/: No such file or directory
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
/tmp/iRedMail-0.7.2/functions/roundcubemail.sh: line 365: cd: /var/www/roundcubemail-0.5.3/config/: No such file or directory
/tmp/iRedMail-0.7.2/functions/roundcubemail.sh: line 368: cd: /var/www/roundcubemail-0.5.3/plugins/password/: No such file or directory
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
Can't open config.inc.php: No such file or directory.
<<< SKIP >>> Skip function: phpmyadmin_install.
<<< SKIP >>> Skip function: awstats_config_basic.
<<< SKIP >>> Skip function: awstats_config_weblog.
<<< SKIP >>> Skip function: awstats_config_maillog.
<<< SKIP >>> Skip function: awstats_config_crontab.
<<< SKIP >>> Skip function: iredadmin_config.
<<< SKIP >>> Skip function: iredapd_config.
<<< SKIP >>> Skip function: fail2ban_config.
<<< SKIP >>> Skip function: cleanup.

I think the installer comes to the conclusion most of it is install already or something, any idea what I could try besides a full OS re-install?

2 (edited by sn0x0r 2011-07-22 21:05:16)

Re: Trying a re-install, skips all however!

Okay, I tried to install the 0.7.3-rc2 instead.

This one installed, but once i issued the 'for loop' to start all the needed services it couldn't start a few of them.

[root@naboo iRedMail-0.7.3-rc2]# for i in iptables syslog  httpd postfix mysqld policyd dovecot amavisd clamd fail2ban crond freshclam iredapd; do /etc/init.d/${i} restart; done
Flushing firewall rules:                                   [  OK  ]
Setting chains to policy ACCEPT: filter                    [  OK  ]
Unloading iptables modules:                                [  OK  ]
Applying iptables firewall rules:                          [  OK  ]
Loading additional iptables modules: ip_conntrack_netbios_n[  OK  ]
Shutting down kernel logger:                               [  OK  ]
Shutting down system logger:                               [  OK  ]
Starting system logger:                                    [  OK  ]
Starting kernel logger:                                    [  OK  ]
Stopping httpd:                                            [FAILED]
Starting httpd: Syntax error on line 7 of /etc/httpd/conf.d/iredadmin.conf:
Invalid command 'WSGISocketPrefix', perhaps misspelled or defined by a module not included in the server configuration
                                                           [FAILED]
Shutting down postfix:                                     [FAILED]
Starting postfix:                                          [  OK  ]
Stopping mysqld:                                           [  OK  ]
MySQL Daemon failed to start.
Starting mysqld:                                           [FAILED]
Stopping policyd:                                          [  OK  ]
Starting policyd:                                          [  OK  ]
Stopping Dovecot Imap:                                     [FAILED]
Starting Dovecot Imap:                                     [  OK  ]
Shutting down Mail Virus Scanner (amavisd):                [  OK  ]
Starting Mail Virus Scanner (amavisd): fetch_modules: error loading required module Compress/Zlib.pm:
  Compress::Raw::Zlib version 2.033 required--this is only version 2.03 at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 11.
  BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 11.
  Compilation failed in require at /usr/sbin/amavisd line 197.
ERROR: MISSING REQUIRED BASIC MODULES:
  Compress::Zlib
BEGIN failed--compilation aborted at /usr/sbin/amavisd line 237.
                                                           [FAILED]
Stopping Clam AntiVirus Daemon:                            [FAILED]
Starting Clam AntiVirus Daemon: Bytecode: Security mode set to "TrustSigned".
LibClamAV Warning: **************************************************
LibClamAV Warning: ***  The virus database is older than 7 days!  ***
LibClamAV Warning: ***   Please update it as soon as possible.    ***
LibClamAV Warning: **************************************************
                                                           [  OK  ]
Stopping fail2ban:                                         [  OK  ]
Starting fail2ban:                                         [  OK  ]
Stopping crond:                                            [  OK  ]
Starting crond:                                            [  OK  ]
freshclam is already stopped.                              [  OK  ]
Starting freshclam:                                        [  OK  ]
Stopping iredapd ...
Starting iredapd ...

[edit]
Already fixed the problem with Amavis not starting.

Installed the PERL Compress:Zlib module, and then manually created a pem in the right location, setfacl'ed it and that fixed it.

I'm still not sure what's wrong with httpd or mysqld though.

I've got a feeling the problem with mysql is in the socks file. Following up on this now. No clue what to do about httpd not starting so far. (The error is clear, but I haven't found anything about this yet)

[edit2]
The httpd one was easy eventually, just added a LoadModule wsgi_module to the httpd.conf.

Now all that's left is trying to get Mysql running, which still seems to be related to the socks file, since my.cf is saying the socks file should be at:

/var/lib/mysql/mysql.sock

Yet nothing is there.

[edit3]

110722 15:01:36 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
110722 15:01:36 [Note] Plugin 'FEDERATED' is disabled.
110722 15:01:36 InnoDB: The InnoDB memory heap is disabled
110722 15:01:36 InnoDB: Mutexes and rw_locks use GCC atomic builtins
110722 15:01:36 InnoDB: Compressed tables use zlib 1.2.3
110722 15:01:36 InnoDB: Using Linux native AIO
110722 15:01:36 InnoDB: Initializing buffer pool, size = 128.0M
110722 15:01:36 InnoDB: Completed initialization of buffer pool
110722 15:01:36 InnoDB: highest supported file format is Barracuda.
110722 15:01:37  InnoDB: Waiting for the background threads to start
110722 15:01:38 InnoDB: 1.1.8 started; log sequence number 1694940
110722 15:01:38 [ERROR] /usr/libexec/mysqld: unknown variable 'default-character-set=utf8'
110722 15:01:38 [ERROR] Aborting

110722 15:01:38  InnoDB: Starting shutdown...
110722 15:01:38  InnoDB: Shutdown completed; log sequence number 1694940
110722 15:01:38 [Note] /usr/libexec/mysqld: Shutdown complete

110722 15:01:38 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

The error log of the MySQL problem. I googled for the error and i found i had to disable this:

[mysqld]
#bind-address            = 127.0.0.1
port                    = 3306
default-character-set   = utf8

to this:

[mysqld]
#bind-address            = 127.0.0.1
port                    = 3306
#default-character-set   = utf8

Because apparently the "default-character-set   = utf8" is also called under the [client] part of the file.

Doing this however didn't solve the actual problem, because this is the new error log after disabling that line:

110722 15:04:37 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
110722 15:04:37 [Note] Plugin 'FEDERATED' is disabled.
110722 15:04:37 InnoDB: The InnoDB memory heap is disabled
110722 15:04:37 InnoDB: Mutexes and rw_locks use GCC atomic builtins
110722 15:04:37 InnoDB: Compressed tables use zlib 1.2.3
110722 15:04:37 InnoDB: Using Linux native AIO
110722 15:04:37 InnoDB: Initializing buffer pool, size = 128.0M
110722 15:04:37 InnoDB: Completed initialization of buffer pool
110722 15:04:37 InnoDB: highest supported file format is Barracuda.
110722 15:04:37  InnoDB: Waiting for the background threads to start
110722 15:04:38 InnoDB: 1.1.8 started; log sequence number 1694940
110722 15:04:38 [ERROR] /usr/libexec/mysqld: unknown option '--skip-locking'
110722 15:04:38 [ERROR] Aborting

110722 15:04:38  InnoDB: Starting shutdown...
110722 15:04:39  InnoDB: Shutdown completed; log sequence number 1694940
110722 15:04:39 [Note] /usr/libexec/mysqld: Shutdown complete

110722 15:04:39 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

Trying to google on that error however didn' provide any results whatsoever.

3

Re: Trying a re-install, skips all however!

In order to get MySQL started I had to disable the following lines in my.cnf.

default-character-set   = utf8 (The one under [mysqld])
skip-locking
set-variable = max_connections=1024

After that it finally started. I haven't yet found out what the implications might be on disabling these settings though.