1 (edited by mbsouth 2009-09-03 22:39:28)

Topic: Aliases problem

Strange things happens.
Today I created an alias -> postmaster@example.com. It points to office@example.com (mailbox) [address -> goto].
When I sent a message to postmaster@example.com I got this in the mail.log:

NOQUEUE: reject: RCPT from external.mailserver.local[x.x.x.x]: 450 4.1.1 <postmaster@example.com>: Recipient address rejected: unverified address: Address verification in progress; from=<user@mailserver.local> to=<postmaster@example.com> proto=ESMTP helo=<external.mailserver.local>

I test it like:
postmap -q postmaster@example.com proxy:mysql:/etc/postfix/mysql_virtual_alias_maps.cf

After that I tried any other aliases. The same happens. Any idea?



Re: Aliases problem

Could you please show the SQL query result?

mysql> USE vmail;
mysql> SELECT * FROM alias WHERE address='postmaster@example.com';
mysql> SELECT * FROM mailbox WHERE username='office@example.com';



Re: Aliases problem

SELECT * FROM alias WHERE address='postmaster@example.com';
=> postmaster@example.com, office@example.com [address,goto]

SELECT * FROM mailbox WHERE username='office@example.com';
=> office@example.com, the_password, Office, /var/vmail/example.com/office ...



Re: Aliases problem

hi, sir. i just want to check other columns. please paste all output result. (Just HIDE/CHANGE password field)



Re: Aliases problem

Sorry about that!

postmaster@example.com,office@example.com,example.com,2009-09-03 01:48:18,2009-09-03 14:56:02,9999-12-31 00:00:00,1

'office@example.com', xxxx, 'office', '/var/vmail/vmail01', 'example.com/office/', 100, 'example.com', 'dovecot', '', 'normal', NULL, 1, 1, 1, 1, 1, '0000-00-00 00:00:00', 0, '', '2009-08-22 01:48:18', '2009-08-29 22:47:32', '9999-12-31 00:00:00', 1

If I comment out
#enable_original_recipient = no it works again!



Re: Aliases problem

Did you change other postfix parameters?



Re: Aliases problem

I believe, I destroyed something by playing arround with postfix settings.
I´ll restore the changes with an image I made some days ago. 

Btw. in main.cf in line
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$myhostname
should be
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$mydomain
Of course its possibly that I changed this. Can you check it?

It is advantageous to use postfix´s proxymap (proxy:mysql:......) instead of (mysql:....)?
I also tried to use amavis tmp directory with ramdisk (tmpfs). It works but there is not enough traffic on my test environment to evaluate this.